KB-2164 Application server cannot start with "Failed to create DesignObjectSchema" errors in high availability or distributed environments
Symptoms
In a highly-available or distributed Appian environment, the application server fails to start and the following error error is logged in the application server logs:
ERROR com.appiancorp.ads.designobjects.schema.DesignObjectSchemaManager - APNX-1-4408-001 - Failed to create DesignObjectSchema.
ERROR com.appiancorp.applicationpatch.PatchSchemaManager - APNX-1-4506-001 - Failed to connect to data server. The ability to store and retrieve application patches will not be available until the connection is reestablished. Check the status of the data server.
Although the errors indicate an issue with the data server, the data server itself may start and run, but the application server on all nodes in the high availability set-up fail to start successfully as a result.
Cause
This error can appear when the data-server-sec.properties file is inconsistent between all nodes where the application server or data server is installed. See the following documentation for more details.
Action
- Follow the documented procedures to set the security token and ensure that the
dataserver.passwordproperty is consistent across all distributed nodes. - Restart the data server according to the steps listed in the documentation and confirm that the process is running.
- Start the application server.
Affected Versions
This article applies to Appian 19.4 and later.
Last Reviewed: November 2020
