You are currently reviewing an older revision of this page.

KB-1000 Issues related to appian.sec file in Appian

Symptoms

Users may experience one or more of the following symptoms in their distributed installation:

Symptom 1

The check engine script, checkengine.bat|sh located in <APPIAN_HOME>/server/_scripts/diagnostic, is used to monitor the status of the engines.

In a dual gateway setup, the output of checkengine.bat|sh on each engine server reports only 0/2 or 1/2 active gateways and a server timeout after 30 seconds message. This is indicative of one set of gateways being unable to communicate with the other.

For example, the checkengine.bat|sh output for Process-Exec02 on server 1 shows:

Process-Exec02   1/2     * ERROR     Server timeout (30 sec.) on GW2.

The checkengine.bat|sh output on server 2 shows:

Process-Exec02    1/2     * ERROR Server timeout (30 sec.) on GW1.

After enabling DEBUG logging (see Application Engine and Gateway Logging for more information), the following can be seen in gw_*.log:

2015-07-20 08:51:29 [CH1] INFO .a.gw "State transition from [DISCONNECTED] to [ACTIVE JOIN]"
2015-07-20 08:51:30 [CH1] DEBUG .a.gw.swj "I am (`"XX.XXX.X.XXX";XXXX)"
2015-07-20 08:51:30 [CH1] INFO .a.gw.swj "Join attempt #1 to XXXX:XXXX"
2015-07-20 08:51:30 [CH1] DEBUG .a.gw.swj "cc _w=4"
2015-07-20 08:51:40 [CH1] DEBUG .a.gw.swj "I am (`"XX.XXX.X.XXX";XXXX)"
...
2015-07-20 08:52:20 [CH1] INFO .a.gw.swj "Join attempt #6 to XXXX:XXXX"
2015-07-20 08:52:20 [CH1] DEBUG .a.gw.swj "cc _w=4"
2015-07-20 08:52:21 [CH1] INFO .a.gw.swj "Switching to [STANDALONE] after 6 join attempts"
2015-07-20 08:52:21 [CH1] INFO .a.gw "State transition from [ACTIVE JOIN] to [STANDALONE]"

Symptom 2

On deploying a hotfix to a distributed environment, the following error, for example, is seen in the application server log:

ERROR com.appiancorp.kougar.driver.ipc.IpcConnection - Failure to read socket: personalization (XXX.XXX.XXX.XXX:XXXX)
java.io.EOFException: Socket returned no more data at end of stream: personalization (XXX.XXX.XXX.XXX:XXXX)

Cause

The following are possible causes for these symptoms:

  • The appian.sec file in the <APPIAN_HOME>/ear/suite.ear/conf directory (if present) is different between the two servers. The configure script in the newer versions deploys this file at the ear/suite.ear/conf location
  • The machines hosting the gateways cannot communicate with each other.

Action

  1. Copy the correct appian.sec files located in <APPIAN_HOME>/ear/suite.ear/conf to all the machines in the environment. Perform a full restart of the environment, including application server, search server, and engines.
  2. Confirm that the machines hosting the gateways are able to communicate with each other by using a network utility such as telnet.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: February 2017