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KB-XXXX Emails from Appian not being received by end users

Symptoms

After a change to the site domain or the creation of a custom email sender, users are reporting emails from Appian are not being delivered within a timely manner to their company issued email address.

Cause

Both of these changes allow Appian to send emails under a customer owned domain. Oftentimes, these changes also require you to update the SPF record for your domain to include the Appian SPF record.

Action

To address this issue, please do the following:

  1. Check the SPF record that the Appian Cloud site is using. This can be done with the following command: nslookup -type='txt' <FULL_SITE_FQDN>.
  2. Work with your mail server admin team to add an include record for the Appian Cloud sites SPF record.
    1. When reviewing the SPF record for the Appian Cloud site, ensure that you are providing the value for canonical name to your mail server admin for them to add the include statement in their SPF record with that value.

Affected Versions

This article applies to all versions of Appian.

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