You are currently reviewing an older revision of this page.

DRAFT KB-[SP-7068] "The field [fieldName] does not exist" error when opening a record

Symptoms

When loading a record type, the error The field [fieldName] does not exist appears.

Other details:

  • This error may not have appeared previously for the same record type.
  • This error may not appear for a record type with the same configuration in another environment.

Cause

Intermittently, when a record type is registered the rf! variables become case sensitive and must match the casing in the related custom data type. Instances a record type would be registered include environment restart and record type deployment. This issue has been reported to the Appian Product Team. The reference number for this issue is AN-185807.

Workaround

Apply either of the following changes to the affected record type:

  • Update the casing of all references fields using rf! to match the casing in the custom data type.
  • Update the legacy record type to a modern record.

Affected Versions

This article applies to all versions of Appian using legacy record types.

Last Reviewed: October 2021