You are currently reviewing an older revision of this page.

KB-1274 "ORA-01017: invalid username/password; logon denied" error thrown during application server startup

Symptoms

During the application server startup, the following is printed in the console and the application server log:

WARN  [org.jboss.jca.core.connectionmanager.pool.strategy.OnePool] (ServerService Thread Pool -- 55) IJ000604: Throwable while attempting to get a new connection: null: javax.resource.ResourceException: Could not create connection
    at org.jboss.jca.adapters.jdbc.xa.XAManagedConnectionFactory.getXAManagedConnection(XAManagedConnectionFactory.java:525)
    at org.jboss.jca.adapters.jdbc.xa.XAManagedConnectionFactory.createManagedConnection(XAManagedConnectionFactory.java:434)
...
Caused by: java.sql.SQLException: ORA-01017: invalid username/password; logon denied

Cause

There are two possible causes for this issue:

  1. The username and/or password the application server is using to connect to the database are not correct.
  2. The “$” character is included in the password, which has been known to cause issues when JBOSS attempts to connect to Oracle databases.

Action

  1. Check that you can login directly to the database using the username and plaintext password. If not, update the username and password to the correct credentials.
  2. Ensure that the password JBOSS is using to connect to the Oracle database does not contain the “$” character.

Affected Versions

This article applies to all versions of Appian using Oracle as a database.

Last Reviewed: March 2017