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Unable to initiate a new health check

Symptoms

The user is unable to initiate a new health check even though there are no running health checks in the system. If using the Health Check Application, the following error will be seen:

If performing manual collection via the servlet, you will see the following:

Cause

When the Health Check runs, it creates a file in the system called health-check-status.json. If the Health Check is cancelled before it completes, the health-check-status.json file will identify the status as 'RUNNING'. The user will be unable to initiate a new Health Check even though it does not seem like there are any active Health Check processes running.

Action

  1. Navigate to /designer and click on the Documents tab. 
  2. In the search bar, search for the file health-check-status.json. When you click on it, the file will download to your computer.
  3. Open the file in an editor and if it indicates the status as 'RUNNING', proceed with the steps below.
  4. Navigate to /design and create a process model with the node Delete Document found under Document Management Smart Services
  5. Configure the Data tab of the Delete Document node. Simply click on Document, and indicate the value as 'health-check-status.json'
  6. Save, publish, and run the process model
  7. Search /designer for the file to ensure it has been deleted
  8. You can now delete the process model