You are currently reviewing an older revision of this page.

Health Check reports X% of users with unsupported browser

Symptom

The Health Check Analysis Report incorrectly reports that a certain number of users are using an unsupported browser version for the particular Appian version. For example, the Details tab of the Health Check Report may show something like the following: 287 users (95.03%) have been using unsupported browser versions for Appian 16.1.0.0 between 2017-03 and 2017-05.

Cause

The Health Check reports on the user-agent string. Although a supported browser may be installed, if it is run in compatibility mode, the user-agent string can be altered. This is why the Health Check might not accurately reflect the browser version. Below is an example of a user-agent string for Internet Explorer being run in compatibility mode. 

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E)

Action/Workaround?

Take the browser out of compatibility mode.