You are currently reviewing an older revision of this page.

KB-XXXX DEFLATE module settings

Symptoms

When logging into the Appian Suite for the first time or after the browser cache has been cleared, users connecting from small or slow networks may notice a long page loading time.  A network capture will display large file sizes which correspond to long component loading times.

An example network capture on a small connections with large file sizes may display:

Protocol Method Result Content type Received Time
HTTPS GET 200 application/javascript 4.79 MB 15.87 s
HTTPS GET 200 application/javascript 6.29 MB 14.24 s
HTTPS GET 200 application/javascript 1.17 MB 2.91 s
HTTPS GET 200 application/javascript 510.42 KB 2.49 s
HTTPS GET 200 application/javascript 496.62 KB 2.67 s

Cause

When logging in to the Appian Suite with a slow or small connection for the first time or after the browser cache has been cleared, several files are downloaded as part of the user interface for the Appian Suite.  For subsequent logins, these files are cached and will be served from the browser cache which improves the page loading time.

Action

To address the size of the browser files which are downloaded when connecting from small or slow networks, consider the following:

  • To reduce the size of the browser files which are downloaded:
    • Please refer to the Configure Compression Using the Deflate Module documentation to configure the compression of javascript, .CSS, and plain text files served by Appian.  Compressing the files served by Appian, by using the Deflate module, will reduce the bandwidth these files consume.
  • Set the user start pages to a Site instead of Tempo to reduce the number of large files downloaded to the browser.  The file size for Sites are smaller since Sites are simpler and allow users to focus on a limited set of activities.  Refer to the User Start Pages documentation to configure user start pages.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: April 2018