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KB-XXXX: Database connections issue in 17.4 and 18.1

 

Symptoms

The number of secondary data source connections, configured in the Admin Console, pointing to an Oracle database would climb up by a factor of five. This will cause a high number of inactive connections to the database indicating a high load from the application. 

Cause

There was a data source connection leak in the code that logs data source metrics for data sources defined through Admin Console. This issue has been resolved via AN-105369 in the following hotfixes/versions:

Action

Apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian. 

Workaround

  1. Make sure the user has read/write/execute access on the server.
  2. Open the log4j.properties file located in <APPIAN_HOME>/ear/suite.ear/resources/appian_log4j.properties
  3. Set the value of log4j.logger.com.appian.data-metrics.data_sources from INFO to FATAL. It should look like this: log4j.logger.com.appian.data-metrics.data_sources=FATAL, DATA_SOURCES_METRICS
  4. Restart application server to clear out the inactive sessions

Affected Versions

This article applies to Appian 17.4 and later.