You are currently reviewing an older revision of this page.

[DRAFT SP-9623] Kafka/Zookeeper/Tomcat related data ownership being non-Appian user account prevents services from starting up

Symptoms

Upon starting services, the console output shows the following:

Starting Kafka...
waiting for process Kafka
process Kafka running
local Kafka broker is not registered
<<< Kafka broker initialization failed for localhost:9092. Check the broker logs for more information >>>
Deleting Kafka index files in case initialization failed due to a corrupt index file.
Unable to start service Kafka
com.appian.komodo.translog.KafkaNotRunningException: Kafka process died

Inside the server.log, the one or more of following error(s) are shown:

[YYYY-MM-DD HH:MM:SS,mmm] ERROR Error while loading log dir /usr/local/appian/appian224/appian/services/data/kafka-logs (kafka.server.LogDirFailureChannel) java.nio.file.AccessDeniedException: /usr/local/appian/appian224/appian/services/data/kafka-logs/serviceManager.transaction.<engine>-#/####################.log
[YYYY-MM-DD HH:MM:SS,mmm] ERROR Error while deleting the clean shutdown file in dir <APPIAN_HOME>/services/data/kafka-logs (kafka.server.LogDirFailureChannel)
java.nio.file.AccessDeniedException: <APPIAN_HOME>/services/data/kafka-logs/serviceManager.transaction.<engine>-#/####################.log

Cause

Necessary component files are owned by non-Appian user accounts.

Action

To check the file permissions inside the environment, run the following:

  1. Check to see if files are owned by different users in Appian_home
    1. sudo find <Appian_home> -printf '%u:%g\n' | sort -t: -u
    2. For High Availability (HA) Sites: sudo find -L <Appian_home> -printf '%u:%g\n' | sort -t: -u
  2. Change ownership to be under the Appian user
  3. Attempt startup
  4. If the issue persists, open a support ticket for further investigation.

Affected Versions

This article applies to all self-managed versions of Appian.

Last Reviewed: March 2024