You are currently reviewing an older revision of this page.

KB-XXXX Export to Excel smart service fails with insufficient memory error

Symptoms

While running the OOTB Export to Excel smart service, the node fails and the following error is seen in the app server log:

INFO  [stdout] (Appian Work Item - 535374 - ProcessExec01 : UnattendedJavaActivityRequest) 2018-01-22 06:30:38,869 [Appian Work Item - 535374 - P
rocessExec01 : UnattendedJavaActivityRequest] ERROR com.appiancorp.process.engine.UnattendedJavaActivityRequest - An error occurred while executing activity:
id=268449513, classname=com.appiancorp.process.runtime.activities.DataExportEntitySmartService5
INFO  [stdout] (Appian Work Item - 535374 - ProcessExec01 : UnattendedJavaActivityRequest) com.appiancorp.suiteapi.process.exceptions.SmartServic
eException: The export operation has been aborted due to insufficient memory. Consider filtering your data, or reducing the number of columns being fetched if
 you are trying to export a large data set.

Cause

The amount of data in the current batch being exported is larger than the currently configured query memory limit.

This limitation has been reported to the Appian Product Team as AN-100029.

Workaround

On-premise customers may increase the query memory limit to allow larger batches of data to be processed. Please take note of the memory and performance considerations mentioned in the query memory limit documentation before increasing this setting by a large amount:

  1. Shutdown the application server
  2. In custom.properties, increase the value of conf.data.memory.limit by 1 MB
  3. Start the application server
  4. Repeat steps 1-3 until the node succeeds

Alternatively, customers should:

  • Reduce the number of columns being exported.
  • Reduce the size of any large columns being exported (e.g. a column defined as varchar(10000))

Affected Versions

This article applies to Appian version 17.4 and above.