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DRAFT KB-XXX News Posts missing in Tempo

Symptoms

Past News Posts (greater than approximately 1 week old) are missing from Tempo. However, the older News Posts are present when running the following SQL query in the Appian Primary Data Source:

SELECT * FROM tp_feed_entry ORDER BY id ASC;

Cause

News Posts are stored in the Appian Primary Data Source in the tp_feed_entry table. For quick retrieval, these posts are indexed. If these indices become corrupted, the indexing must be restarted, causing only new entries to be stored and displayed in Tempo. The descriptions below describe how these indices can become corrupted:

Appian 17.1 and 17.2

  • These News Posts are indexed by Apache Lucene. The index files are stored in the <APPIAN_HOME>\_admin\search-local\index-primary directory.
  • Explain how this can get corrupted.

Appian 17.3 and Beyond

  • These News Posts are indexed the Search Server. The index files are stored in the <APPIAN_HOME>\_admin\search-local\search-server\data\appian-search-cluster\nodes\0\indices directory.
  • If Search Server experiences an issue (i.e. crashes due to network issue or runs out of disk space), the indices may be corrupted.
  • The root cause of the Search Server crash can be determined by examining the Search Server logs located at <APPIAN_HOME>\logs\search-server.

Action

  1. Review the <JBOSS_HOME>\standalone\deployments\*-ds.xml and confirm that the environment is pointing to the correct Primary Data Source.
  2. Once confirmed, connect to the Primary Data Source and run the following query: SELECT * FROM tp_feed_entry ORDER BY id ASC;
  3. Inspect the content returned by the query. If the content contains old News Posts (that are missing from Tempo), proceed to the following steps:

Appian 17.1 and 17.2

  1. In the <APPIAN_HOME>\_admin\search-local\index-primary directory, open the lastsync.properties file.
  2. Delete the contents of the lastsync.properties file and save it.
  3. Wait a few minutes and check that the lastsync.properties file has been repopulated with a new timestamp and that the News Feed entries are now showing up.

If the above procedure does not resolve the issue, proceed with the following steps:

  1. Stop Appian.
  2. Delete the the <APPIAN_HOME>\_admin\search-local\index-primary directory.
  3. Start Appian.
  4. Check that the lastsync.properties file has been repopulated with a new timestamp and that the News Feed entries are now showing up.

Appian 17.3 and Beyond

  1. Stop the application server and search server.
  2. Delete the the <APPIAN_HOME>\_admin\search-local\ directory.
  3. Start the application server and search server.

Affected Versions

This article applies to Appian 17.1 and later.

Last Reviewed: June 2018