KB-1622 Sending an email with an attachment to a process in Appian Cloud fails
Symptoms
Sending an email with a large attachment to a process in Appian Cloud fails. The total size of the email is less than the 25 MB limit for Appian Cloud. The application server log prints the following error:
ERROR com.appiancorp.process.engine.UnattendedJavaActivityRequest - An error occurred while executing activity: id=7652, classname=com.appiancorp.process.runtime.activities.SendEmailActivity com.appiancorp.suiteapi.process.framework.ActivityExecutionException: Failed to process attachments ... Caused by: com.appian.komodo.api.exceptions.SignalException: E106
Cause
This is due to the overhead in encoding the email attachments. The 25 MB limit is based on the encoded message size, not the original or raw file size. The encoding adds about 33% overhead. Due to this, depending on the attachment the practical limit is around 18 MB.
Action
Try compressing the attachment or use a file share system instead.
Affected Versions
This article applies to all versions of Appian Cloud.
Last Reviewed: September 2019
