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DRAFT KB-XXXX 18.4 custom email sender functionality "Return-Path" and "Sender" fields differ from the old custom email sender functionality

Symptoms

When testing the new feature to Configure Custom Email Senders Inline, emails may not be received by certain mail servers. Upon further inspection, it is noticeable that the Sender header and the Return-Path header do are not the same as the Sender Email address field configured in the Send Email Smart Service node.

For example, the Send Email Smart Service node is configured as follows:

However, instead of seeing "help@example.com" in the Sender header and the Return-Path header, these headers display a different value such as "admin@sitename.appian.com" as seen below:

Return-Path: <admin@sitename.appian.com>
From: IT Service Desk <help@example.com>
Sender: <admin@sitename.appian.com>
To: <recipient@example.com>

This may result in emails failing to deliver to certain servers if these servers only accept mail from the domain "*@example.com" and block mail from other domains such as "*@sitename.appian.com" or "*@sitename.appiancloud.com".

Cause

The Appian 18.4 Configure Custom Email Senders Inline feature was designed this way. As the feature introduced the ability for any designer to select any sender email and sender display name, it was important to make it explicitly clear that the email is being sent by the system on behalf of an email, rather than from the email directly. Therefore, the feature will set the Sender header and the Return-Path header to the #site value specified in custom.properties (typically admin@sitename.appian.com). This is the intended behavior of the 18.4 custom email sender, and designers cannot circumvent this.

Action

 

Affected Versions

This article applies to Appian 18.4 and later.

Last Reviewed: March 2019