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KB-1144 Appian attempts to overwrite files in accdocs folders after an upgrade

Symptoms

After an upgrade to a new version, you see errors in the application server log that state the system is attempting to overwrite files in the _admin\accdocs* folders. The server eventually fails to start. The log messages are similar to the one below:

INFO  [stdout] (ServerService Thread Pool -- 73) com.appiancorp.ix.ConsumerException: type=content, srcId=SYSTEM_CONTENT_ICON_INDICATOR_MOVE_DOWN, dstId=8668, cause=com.appiancorp.suiteapi.common.exceptions.AppianException: java.lang.IllegalArgumentException: Attempt to write over a file that already exists: ##PATH TO FILE IN ACCDOCS##, level=ERROR, object=ContentHaul[content=[Content:id=8668,name=iconIndicatorMoveDown,description=,type=1,uuid=SYSTEM_CONTENT_ICON_INDICATOR_MOVE_DOWN,parent=92,visibility=20,security=143,attributes={},partition=2147483647],resourceName=move_down.png,roleMap=com.appiancorp.suiteapi.content.ContentRoleMap@1565d0ce[

INFO  [stdout] (ServerService Thread Pool -- 73) Caused by: java.lang.IllegalArgumentException: Attempt to write over a file that already exists: ##PATH TO FILE IN ACCDOCS

Cause

This usually happens during upgrades with improper migrations or when the contents of the _admin folder have been moved around.

The cause for this is that the Collaboration engine has a mismatch with the _admin/accdocs folders. Specifically, the Collaboration engine has an internal counter that determines the next internal filename when creating a file. If the internal file already exists, then this will cause a conflict in the filename and the server may not start.

Action

  1. If you are upgrading from a previous version, make sure that you copied the highest numbered engine database file *.kdb from the old directory to the new installation’s directory. If you move the *.kdb for any reason, you also have to move the contents of the _admin folder.
  2. In case of an unsuccessful upgrade, roll back to a backup from before the upgrade and attempt the migration again. Do not use the existing data to roll back, as there might be additional system files generated during the unsuccessful upgrade attempt.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: September 2018