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KB-1269 Missing default system icons in end user interface

Symptoms

There are missing system icons when browsing Tempo (News, Records, Reports etc.) and the icon’s associated “PNG” file is missing from the <APPIAN_HOME>/_admin/accdocs* directory. An example of what a missing “default record icon” could look like is pictured below.

Note: Different browsers may use different icons to symbolize a missing or broken picture (in this case the black box with an x in the middle):

If you perform a network capture on the browser page containing the missing icon(s), you will see a REST call for the icon in question return with a 404 error (indicating the file was not found).

Cause

The application server is not able to to find and display the icon in the browser because the icon’s associated PNG file is either missing entirely from the <APPIAN_HOME>/_admin/accdocs* directory or it is present but has an outdated file name (meaning the application server will be referencing the wrong filename for the icon).

Action

Action 1

  1. Import the specific bundled app zip file from the <APPIAN_HOME>/ear/suite.ear/web.war/WEB-INF/bundled-apps/ directory through Appian Designer. (e.g., import records.zip for a missing default icon in Records).
  2. Shut down the application server.
  3. Clear the application server cache as per KB-1232.
  4. Start the application server.

Action 2

  1. Import the following:
    1. The specific bundled app zip file from the <APPIAN_HOME>/ear/suite.ear/web.war/WEB-INF/bundled-apps/ directory through Appian Designer. (e.g., import records.zip for a missing default icon in Records).
    2. Select the "Include related import customization file" checkbox.
    3. Within the "Import Customization File (PROPERTIES)" section, upload a import.properties file which has the following contents:
      ## Import Setting: Force Update
      ## Forces the import of objects that were detected to be Not Changed on inspect/import
      importSetting.FORCE_UPDATE=true
  2. Shut down the application server.
  3. Clear the application server cache as per KB-1232.
  4. Start the application server.

Action 3

If you have a backup of icon(s) elsewhere, do the following:

  1. Perform a network capture on the browser page where the missing icon(s) is located.
  2. Identify the file name of the missing icon(s) and the source folder the file is supposed to be inside of.
  3. Place the backup of the icon(s) within that folder.
  4. Rename the backup of the file so that it matches the name of the missing icon(s).
  5. Shut down the application server.
  6. Clear the application server cache as per KB-1232.
  7. Start the application server.

If the above actions do not resolve the issue please create a support case with Appian Technical Support to determine the best path forward.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: May 2019