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KB-1432 Blank items in Knowledge Center

Symptoms 

When navigating to a Knowledge Center page from designer, users encounter items listed that have no names and appear to be blank items.

Cause 

This can happen when documents are added or moved directly to the Knowledge Center, instead of a folder. Knowledge Centers should only contain folders. Within those folders are where the documents should exist. 

Action

  1. Deploy the Custom Content Functions plug-in.
  2. Navigate to the parent of the problematic Knowledge Center, select the checkbox of the problematic Knowledge Center, click Properties in the toolbar, and copy the Knowledge Center ID.
  3. Run the following expression where kcId is the id from the previous step: getdocumentsfromfolder(ri!kcId,false). This will give you a list of Ids of the documents that are directly under the KC, instead of the folder within the KC.
  4. Create a process model with a Move Document node.
  5. Create a process variable called pv!docToMove of type Document and set it as a parameter.
  6. In the "Document" field type, set pv!docToMove.
  7. In the Destination select the destination folder, e.g. Temporary Documents folder.
  8. Create a start form for this process so that you can provide the document to move in the start form.
  9. Save and publish the process model.
  10. Start a new instance of this process.
  11. Provide the Id of the document to move and submit the form.
  12. Repeat steps 10 and 11 for each document to be moved from step 3. You can also configure the process model to use MNI and run once instance of "Move Document" per passed document Id.

Affected Versions

Last Reviewed: December 2017