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DRAFT KB-XXXX Cannot edit username when testing LDAP connection

Symptoms

When configuring an LDAP connection, the username to test the connection with cannot be edited. As a result, an incorrect username may be displayed on the test screen, preventing testing and saving the configurations successfully.

Cause

If LDAP authentication is not restricted to a group or if the currently logged in user is part of the LDAP authentication group, Appian automatically assumes that the currently logged in user's credentials should be used to test the connection.

Action

If there is no LDAP user corresponding to the name of the currently logged in user, perform the following to enable editing the LDAP username:

  1. If LDAP authentication is not already restricted to a group, check the "Restrict LDAP authentication to a specific group" checkbox in LDAP settings in the Administration Console.
  2. Restrict LDAP authentication to a group that does not contain the currently logged in user.

If there is an LDAP group already configured, simply remove the currently logged in user from the group.

Affected Versions

This article applies to Appian 7.11 and above.

Last Reviewed: January 2018