You are currently reviewing an older revision of this page.

DRAFT KB-XXXX "An error occurred while retrieving the report" in Task per Process Model report

Symptoms

When looking at the Task per Process Model report, the following error appears:

 

Looking at the JBOSS_HOME/standalone/log/server.log file, you may see the following error:

2016-12-15 19:20:53,204 [ajp-/0.0.0.0:8009-4] ERROR com.appiancorp.process.analytics2.service.ProcessAnalyticsServiceFacade - com.appiancorp.kougar.driver.exceptions.Signal: index
2016-12-15 19:20:53,204 [ajp-/0.0.0.0:8009-4] ERROR com.appiancorp.process.analytics2.display.ProcessAnalyticsReportData - com.appiancorp.kougar.driver.exceptions.Signal: index
java.lang.RuntimeException: com.appiancorp.kougar.driver.exceptions.Signal: index

 

Cause

This issue occurs when the data in the Execution and Analytics engines get out of synchronization and need to be synchronized again.

Action

Resetting the Analytics Engines solves this issue. Refer to KB-1157 How to reset the analytics engines for on-premise installations of Appian for more details.

Affected Versions

This article applies to all versions of Appian.