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DRAFT KB-XXXX "An error occurred while retrieving the report" in Task per Process Model report

Symptoms

When looking at the Task per Process Model report, the following error appears:

The application server log throws the following error:

2016-12-15 19:20:53,204 [ajp-/0.0.0.0:8009-4] ERROR com.appiancorp.process.analytics2.service.ProcessAnalyticsServiceFacade - com.appiancorp.kougar.driver.exceptions.Signal: index
2016-12-15 19:20:53,204 [ajp-/0.0.0.0:8009-4] ERROR com.appiancorp.process.analytics2.display.ProcessAnalyticsReportData - com.appiancorp.kougar.driver.exceptions.Signal: index
java.lang.RuntimeException: com.appiancorp.kougar.driver.exceptions.Signal: index

Cause

This issue can be caused by one of two things:

  1. A constant has been created with the same name as a task metrics.
  2. The Execution and Analytics engines are out of synchronization and need to be synchronized again.

Action

To fix this issue, first verify if a constant exist with the same name as a task metrics. To do so, follow these steps:

  1. Navigate to the Rules tab
  2. Using the search box, check if a constant with any of these names exist: 
    1. task_avg_completion
    2. Completion
    3. task_completion_time
    4. is_process_ontime
    5. is_process_overdue
    6. is_task_favorite
    7. is_task_ontime
    8. is_task_overdue
    9. Lag
    10. NetCompletion
    11. NetLag
    12. NetWork
    13. process_completion_time
    14. process_deadline
    15. process_ee_id
    16. pm_avg_completion
    17. pm_avg_lag
    18. pm_avg_work
    19. process_start_time
    20. task_assignee_owner
    21. task_assignment_time
    22. task_attributed_to
    23. task_avg_lag
    24. task_avg_work
    25. task_deadline
    26. task_ee_id
    27. task_status
    28. total_completion_time
    29. total_lag_time
    30. total_work_time
    31. Work

If a constant with a similar name exists, remove it from the system. 

After making sure that no constants exist with a same name as one in the list above, reset the analytics engines. Please refer to KB-1157 How to reset the analytics engines for on-premise installations of Appian for more details.

Affected Versions

This article applies to all versions of Appian.