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DRAFT SP-6735 How to Report Generic SAML Errors in tomcat-stdOut.log file

Symptom

When logging in to Appian, via a SAML authentication system, the following error can be printed in the application server log:

[ajp-nio-0.0.0.0-8009-exec-3] ERROR com.appiancorp.security.auth.saml.redirecter.SamlAuthProviderQueryStringGenerator - Could not find IdP entity Id: Idp Entity Id not stored on session or request

Cause

This error indicates that a SAML user failed to authenticate. There are numerous causes that can print an error like that. Some of the issues can be related to the SAML setup or it may just be an incorrect credential attempt from an user.

Action

Check with front-end users to confirm if any are having issues logging into Appian. If SAML users do not complain about logging in, then the error most likely means some users failed to login temporarily, but were ultimately able to login. If users are not able to login after multiple login attempts, create a support ticket with the following information:

  1. Tomcat-stdOut.log with the error and timestamp
  2. Attach a screenshot of what users are seeing in the front end
  3. Mention which users are being affected
    1. Is it just some or all userss in the SAML group?
    2. login-audit.csv file will have more details about the which users are unable to login in
  4. Capture a SAML trace for the users who are facing issues logging in

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: September 2021